Le Wifi

décembre 2016 modifié dans Support materiel
Alors je suis sous deepin je kiffe totalement mais il y a un problème des fois le wifi se desactive et je dois tout le temps le reactivé et ça me soule un peu 

Commentaires

  • Salut Emmanuel,
    Ton souci pourrai être ton routeur, ton FAI, ta carte réseau... Le réseau s'est complex, si c'est juste des fois, reviens au début de la phrase...
    Si c'est toutes les 2 minutes, c'est un autre probleme. De plus le wifi fonctionne avec des ondes on est bien d'accord? Un simple micro-onde peut tout à fait te couper le wifi , ça peut dépendre de  beaucoup de choses donc.  J'installe Deepin demain, je verrai bien.
  • C'est aussi possible que le drivers de ta carte wifi ne soit pas terrible...
    Surtout les carte wifi proprio :) 

    Ouvre le gestionnaire de pilote, et regarde si il t'en propose d'autre.
    Si oui, active et redémarre...

    Sinon, on va récupérer la référence pour faire des recherches.
    • Si ton wifi est branché sur USB 
    lsusb
    • Si il est intégré 
    lspci |grep -i net

    Liste des cartes wifi supporté: http://linux-wless.passys.nl/
  • novembre 2016 modifié
    kayoo
    C'est aussi possible que le drivers de ta carte wifi ne soit pas terrible...
    Surtout les carte wifi proprio

    Aussi... wink
    Sur toute les installations Debian que j'ai effectué, j'ai eu des problèmes avec le wifi d'ailleurs, souvent le firmware manquant... Ceci dit, normalement, l'installer de l'OS te l'indique et te demande si tu veux le télécharger à partir d'un périphérique amovible (USB...) maintenant ou plus tard.
    Pour ma propre installation de Deepin je m'y attends un peu, je part d'un pc portable vierge de tout... Rien de méchant...

    Kayoo donne un lien que je ne connaissais pas pour éviter le problème... Merci Kayoo! wink
    Du coup j'aurai pas le temps d'installer Deepin ce matin, dans une heure je suis parti... disappointed 


  • Pourquoi ils sont devenus énorme comme ça les emoticones?
  • Pas de nouvelle, bonne nouvelle ?
  • Salut j'ai eu des problèmes similaires.

    Pour ma part de gros soucis de débits instables (voir déconnexions) avec la carte wifi, et récurent sur certain marques.

    Il suffisait de désactiver l'ip v6 et tout rentre dans l'ordre.

    Dans paramètre tu vas dans réseau puis sur ta connexion wifi en question (petite flèche tout à droite), ensuite tu ouvres le menu déroulant de IP v6 et tu passe la méthode de "automatique" à "ignorer" et là plus de soucis. 

    En espérant qu'il s'agit du même problème pour toi.

    Bon courage
  • merci pour ton retour ONEILRUN.
    Je vais mettre le desactivation de l'IPv6 acessible via deepin-tools.
  • Bonjour !
    Alors personnellement, j'ai le même problème et j'ai tenté la solution de ONEILRUN, le soucis c'est que 1/ si je sauvegarde la désactivation de l'IP v6, tout bug, 2/ même si, sans sauvegarder, je vois une amélioration, c'est encore ultra instable ! Je peux pas mater de streaming sans que ça saute toutes les 5 min, la qualité est mauvaise, et je sais que ce n'est pas ma box parce que même si elle n'a jamais été bien puissante, je n'avais pas ces soucis sous Windows. Des idées ?
  • Salut Phoeby, 

    Tout d'abord as-tu suivit les conseils cité plus haut : 
    1. Activé (si possible) le drivers propriétaires de ta carte wifi
    2. nous lister sa référence afin de rechercher sa compatibilité
    3. Désactiver l'IPv6

    Concernant cette dernière étape, je t'encourage a utiliser notre petit outil maison : 
    => http://forum.deepin-fr.org/discussion/27/outils-deepin-tools-v6/p1

    D'un simple clic, tu pourras désactiver l'IPv6.

    Tiens nous au courant. 
  • Mon meilleur ami a réussi à désactiver l'IPv6 ( avec moi ça voulait pas me reconnecter à ma box ). J'ai pas fais les étapes 1 et 2 pour la simple et bonne raison que je suis tellement nulle en informatique que je serais parfaitement capable de faire une grosse merde xD
  • 12 juin modifié
    C'est difficile d'avoir de l'aide si tu ne fournis pas le type de ta carte wifi. Pour cela ouvre un terminal et exécute cette commande et poste ce qu'elle retourne.
    lspci | grep -i net

    Ps: Tu ne casseras rien avec cette commande, elle ne fait que lister ton matériel réseau.


  • Alors, ça me donne : 
    08:00.0 Network controller : Realtek semiconductor Co., Ltd. RTL8188CE 802. 11b/g/n WiFi Adapter ( rev 01 )
    09:00.0 Ethernet controller : Realtek Semiconductor Co., Ltd RTL8101/2/6E OCI Express Fast/Gigabit Eternet controller ( rev 05 )

    Le ctrl+C a pas voulu marcher avec le terminal donc j'espère ne pas m'être plantée en recopiant ( normalement c'est bon xD )
  • Je vais reprendre la proposition de Kayoo, lance l'application "Gestionnaire de pilotes" et regarde si elle te propose un pilote propriétaire pour ta carte WiFi.
    Le ctrl+C a pas voulu marcher avec le terminal

    Dans le terminal Ctrl+C arrête une commande qu'on a lancée, pour copier dans le presse-papier c'est Ctrl+Maj+C.


  • https://img15.hostingpics.net/pics/996808CapturecranDeepin20170619151019.png Voilà ce que j'ai obtenu ( sachant qu'apparemment, il a pas pu tout télécharger, mais vu qu'il y a déjà des soucis de wifi de base avec ce linux... x) )
  • Tu peux installer le microcode intel mais cela ne résoudra pas ton souci de WiFi.
    J'ai vu sur le web qu'il faut lancer le module rtl81* avec les options ips=0 et fwlps=0, mais avant il faudrait nous donner le retour de cette commande quand la connexion est établie.
    sudo lsmod | grep -i rtl


  • Désolé! j'ai répondu trop vite, n'installe pas intel-microcode. on se concentre sur le problème WiFi.
  • Donc tu veux le retour commande sudo lsmod ? 
  • Oui, si c'est possible.
  • Here we go : 
    rtl8192ce              57344  0
    rtl_pci                28672  1 rtl8192ce
    rtl8192c_common        49152  1 rtl8192ce
    rtlwifi                77824  3 rtl_pci,rtl8192ce,rtl8192c_common
    mac80211              679936  3 rtl_pci,rtl8192ce,rtlwifi
    cfg80211              598016  3 wl,mac80211,rtlwifi

  • 26 juin modifié
    On va appliquer ce qui est indiqué dans le wiki de debian pour essayer de résoudre le souci.
    Exécute ce qui suit et redémarre.
    sudo echo "options rtl8192ce ips=0 fwlps=0" > /etc/modprobe.d/rtl8192ce.conf




  • J'ai tenté et j'ai eus droit à ceci : bash: /etc/modprobe.d/rtl8192ce.conf: Permission non accordée

  • Désolé de cette erreur de syntaxe, je suis un habitué de Fedora, je n'ai pas l'habitude d'exécuter les commandes avec sudo. Exécute plutôt ceci:
    echo "options rtl8192ce ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
  • J'ai obtenu : options rtl8192ce ips=0 fwlps=0
    Je redémarre !
  • 26 juin modifié
    Update ! Alors, je crois que le wifi cesse de faire les yoyo, par contre le débit est toujours pas ouf ! Je suis en train de tenter avec un épisode de série et ça fait 3/4 fois que j'ai dû mettre en pause. J'ai jamais eus un débit de malade, mais avant j'avais quand même pas ce soucis quoi xD

    EDIT : nope, on oublie tout, le wifi saute toujours xD
  • Si la modification qu'on a effectué ne te convient pas et que tu veux revenir à l'état précédent il suffit de supprimer le fichier  /etc/modprobe.d/rtl8192ce.conf et de rebooter.
    sudo rm /etc/modprobe.d/rtl8192ce.conf

  • Bah comme y'a quasi pas de changement, je vais rester sur cette modification là ! Y'a du plus par ci par là, juste ça ne règle pas tout quoi ^^ Merci en tout cas !
Connectez-vous ou Inscrivez-vous pour répondre.