[Outils] Deepin-Tools V6

24

Commentaires

  • Oui ca confirme bien ce que je dis, ce n'est pas une erreur c'est juste un choix qui te sera proposé durant l'installation de nouveau paquet nécessitant un redémarrage.

    Je peux désactiver et forcer le "YES" mais j'attend vos avis pour savoir si vous préférez ce comportement ou non.

  • Je vais te donner mon humble avis , si cet outil est destiné à faciliter grandement la vie des débutants je pense que tu peux forcer le <Yes>, d'autant plus que le <No>est présenté naturellement et c'est une étape ou l'un débutant comme moi ne sera pas quoi répondre . Même si je comprend un peu l'anglais et que j'ai mis <Yes> pour me simplifier la vie car à ce niveau moins on me pose de questions mieux c'est  ;)

    Mais attendons d'autres avis ....
  • Désolé de te submerger , j'ai également testé l'option Nettoyage de printemps , d'une ça fait mal aux yeux la fenêtre qui s'affiche pour la configuration de localepurge et de deux je n'ai rien pu sélectionner à cette étape le curseur est resté bloqué

  • J'avoue pour les locales c'est vraiment pas top !!!
    C'est donc bien une regression avec l'interface graphique...
    Je regarderai ce soir.

    En attendant, j'ai désactivé la purge des locales, remet-a-jour deepin-tools et relance :) 


    Dsl que tu essuies les platres :) 

  • Fait cependant quand cela se termine j'ai le droit à

  • En lançant [Nettoyage de printemps] à al fermeture du script j'ai le droit à ce message en notification
  • Ce serait plus parlant si je pouvais avoir l'image ou la copie du texte qui se trouve dans le terminal :) 


    (Merci de ton aide pour le debug :s )
  • novembre 2016 modifié
    Je comprend pas il veut pas téléchargé ma capture il me dit que le fichier est déjà dans la discussion et qu'il ne sera pas téléchargé à nouveau . Euh ?????
  • Essaye ce service en attendant : https://framapic.org/
  • Bravo bravo et bravo pour cette nouvelle version . merci beaucoup 
  • novembre 2016 modifié
  • C'est bizarre tu as des données de cache dans ta home que tu n'as pas de droits.

    Peux-tu les lister avec la commande : 
    find $HOME -name '*~' -print

    En attendant, j'ai retiré l’arrêt du script sur l’arrêt si il passe sur des répertoires dont les permissions sont non-accordé.

    Remet a jour et relance :)

    @Cyclik

    Ca devrait être corrigé a présent, met a jour et relance :)

  • Bonjour,

    l'installation échoue :

    Installation et mise-à-jour de l'outil Deepin-tools.
    ------------------------------------------------------------------------------


    -- Installation des sources:
    /dev/fd/63: ligne 115: dpkg : commande introuvable

    /!\ Attention:
    ce script nécessite : git


    >> OK

    sudo: apt-get : commande introuvable
    sudo: apt-get : commande introuvable

    Intallation de git terminé
    /dev/fd/63: ligne 235: git : commande introuvable

    * /!\ Un erreur a été détecté ! *


    Une erreur est intervenu dans le script, merci de le signaler directement sur notre forum :
    => http://forum.deepin-fr.org

    Merci d'avance pour votre aide,
    Mickael
  • Pour ma part je te fais suivre mon retour , cela ne change rien , toujours le même message à la fin
  • @cyclik ;
    Un oublie de ma part, j'avais pas repoussé la correction du code...U_U
    Me faut un café :)
    Rebelote: update et relance

    @Mick88
    Le soucis ne dois pas venir de mon script, tu as un retour d'une commande introuvable.
    "dpkg", qui est pourtant un outil de base venant sur toute les distribution Debian core (Deepin, Ubuntu,etc...).

    Es-tu sur de bien tourner sous deepinOS et non Manjaro comme je présume ? 

  • C est bon ;)

    J'avais essayé de m'appuyer des commandes apt-get pour nettoyer
    https://debian-facile.org/doc:systeme:apt:apt-get
    mais les commandes intégrées à ton script sont bien plus efficace .
    Une explication détaillée pour ma culture linuxienne ???  :D
  • Je suis à Ikea, je te fais un topo après;)
  • J'ai une question ou suggestion supplémentaire , toujours pareil pour un débutant lorsqu'on lance la MAJ après une installation toute fraiche de Deepin on tombe sur une proposition de choix de clavier , jusque là rien de bien compliqué on choisit ( bien que perso j'ai jamais su lequel choisir parmi tous ces claviers FR , azerty simplement  ) son clavier puis après on a une autre fenêtre qui s ouvre comme je t ai cité plus haut 



    Puis encore une autre  question



    Alors j'ai tapé "y" mais je me dis que c'est peut être pas logique pour un nouvel arrivant qui ne connait pas Linux , peut être il serait utile d'expliquer que faire , parce que soyons honnête ou alors je suis vraiment très con mais sur ces deux questions j'étais vraiment pas sûr de mes choix et surtout de l'incidence que ça aurait , je suppose que pas mal de personnes ont répondu un peu au pif à ces étapes ou alors je suis le seul imbécile à pas tout comprendre ;)

  • Bonjour Cyclik,

    Après avoir fait le pour et le contre, je vais reprendre mon code pour forcer la main au utilisateur.
    De ce fait, tu ne devrais plus avoir aucun choix possible sur le terminal. A savoir que je vais également prévenir sur mon poste que ces changements comportements un risque (spécialement si on ajoute des dépôts annexe, ce qui n'est pas recommandé)

    Pour le clavier, il s'agit en fait d'une purge des locales de ton système.
    En fait, lorsque tu installes certain logiciel, ils viennent avec toutes les langues, toutes les docs dans toutes les langues,etc.... Cette fonction permettait donc de choisir les langues a conserver. J'ai supprimé cette fonction du nettoyeur en attendant que je trouve comment le forcer ! 

    Merci de ton retour Cyclik.

    @Mick88
    Je n'ai pas eu de retour ? 
  • Salut Kayoo merci pour les explications

    PS: Les commandes intégrées à ton script pour le nettoyage m'intèresse toujours si t as 5 min.
    Juste les commandes après moi je ferai ma recdherche perso pour comprendre
  • N'hésite pas farfouiller dans mon script, il est fort probable qu'il soit coder avec des mouffles mais j'essayerai de répondre a tes questions : https://github.com/kayoo123/deepin-fr.org/blob/master/deepin-fr_tools.sh

    Concernant tes interrogations sur apt et mon nettoyages...
    • apt update => téléchargement du cache dépot
    • apt autoclean => Suppression des archives périmées
    • apt clean => Supressions des paquets en cache
    • apt autoremove => Supression des dépendances inutilisées
    C'est bien de cela que tu souhaitais discuter ? 
  • novembre 2016 modifié
    Super merci pour le lien c'est parfait

    Merci pour les commandes , j'ai même vu sur debian-facile l'option
    --purge autoremove
    Je me régale sur ce site , les docs  sont téléchargeables en plus .
    Je vais  tenter d'établir une connexion en ssh sur le pc de mon père également aussi , j'ai strictement que ça à faire en ce moment , d'ici peu je n'aurai du tout le temps alors j en profite
  • Petite précision , quand j'étais sous firefox et que je tapais du texte je me suis aperçu que le correcteur me corrigeait des mots pourtant écrit dans un bon français .
    D'après mes recherches , j'ai vu que le paquet hunspell-fr n'était pas installé ??? A rajouter au script donc je pense ;)
  • Cyclik, tu dois avoir une mauvaise config avec tout tes soucis anglais/francais...
    Tu as un exemple de site où je peux tester le correcteur ? 


  • Ici tout simplement déjà mais depuis que j'ai installé ce paquet cela fonctionne
  • Moi ca marche très bien sans...
    Dis moi tu as quoi comme paquet firefox ?
    dpkg -l |grep firefox

  • novembre 2016 modifié
    ii  firefox                                  48.0-1                               amd64        Mozilla Firefox web browser
    ii firefox-l10n-fr 48.0-1 all French language package for Firefox
    ii firefox-locale-fr 46.0 amd64 French language pack for Firefox

    Depuis que j'ai installé ce paquet je n'ai plus de problème par contre

    https://doc.ubuntu-fr.org/correction_orthographique#installation_de_correcteurs_orthographiques_dans_les_logiciels_de_bureautique


  • Et bien moi j'ai le paquet "myspell-fr" déjà installé... 
    Mais comme j'install et désinstall assez souvent, c'est pas dit que cela proviens d'une dépendance.

    quelqu'un pourrait lister sont : 
    dpkg -l |grep spell

    Si comme cyclik, vous n'avez pas de base "myspell-fr" ou "hunspell-fr", alors je le rajouterai a la liste :) 

  • Bonjour,

    Je remarque que l'assistant pour le choix du dépot le plus rapide ne marche pas :(

    Output :

    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

    ------------------------------------------------------------------------------
    Remplace automatiquement le dépot de votre systeme par le plus performant.
    ------------------------------------------------------------------------------


    Veuillez patienter pendant que nous determinons le meilleur dépot pour vous...

      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
      0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
    Usage: netselect [-v|-vv|-vvv] [-I] [-m max_ttl] [-s servers] [-t min_tries] host ...

    => Le fichier de configuration du dépot a été modifié avec SUCCES.


    Merci par avance de votre aide :)

Connectez-vous ou Inscrivez-vous pour répondre.