Vivaldi et ffmpeg

Bonjour à tous,
je me retrouve avec une bizarie que je souhaite solutionner:
J'ai donc installer vivaldi via le store Deepin, je peux lire une vidéo sur youtube, mais si je vais sur par exemple: http://vannes.cineville.fr/programmes?salle=vannes_parc , je peux pas lire les bandes annonces. avec Chrome, pas de souci, çà fonctionne
Mais
voilà, je préfère Vivaldi. Ayant contaster que la version proposé est inférieur (1.9 au lieu du 1.12). Puis-je installer la version .deb proposé sur le site ? car, çà m'a affiché "risque instabilité" !  et évidement, cela solutionnera--il mon souci de lecture ?
ou alors, il manque le fameux "ffmpeg", comment puis-je savoir çà ? car, "apt-cache search ffmepg" ne me renseigne pas plus que çà.
Ps: installation Deepin en dure en uefi, carte graphique amd/ati, 8go mémoire vive.
Merci par avance.
Cordialement,
Josélito

Commentaires

  • Bonjour Joselito,

    N'utilisant pas vivaldi je ferai un test pour vérifier avoir le même comportement que toi. 
    En attendant, as tu essayé d'installer la version "vivaldi-beta" qui serait la version 1.12. 

    Pour la video, je me demande si le site ne te la propose pas via flash. 
    Dans ce cas, arrive tu a voir l'image dans cette page ? http://get.adobe.com/fr/flashplayer/about/

    Pourrais-tu faire le même test avec Firefox ? 

  • Bonjour Kayoo, merci de me répondre tout d'abord.



    L'image dans la page ne fonctionne pas, du coup, j'ai été dans les paramètres Vivaldi (/page web) pour activer "toujours activer le plugin flash", et maintenant, je vois l'animation, mais pas l'image (You have version 27,0,0,130 installed). Après redémarrage du navigateur, toujours pas de bandes annonces sur mon site.
    test identique sur Chrome.

    Puis, j'ai omis de préciser que je fais le test de Deepin en dure (j'aime pas la virtualisation). Et que mon OS principal est Calculate Linux (dual boot avec Namib), et que j'avais le même souci avec Vivaldi, qui était réglé au départ avec un overlay d'Adrien_D (vivaldi-ffmpeg-overlay..), puis, c'est en natif dans Calculate maintenant avec media-video/ffmpeg.

    J'en reviens à Deepin; donc, le même souci de vidéos.
    À savoir que du coup, en rapport à ta réponse, je test avec Vivaldi, Firefox et Google Chrome:

    - Viavldi: toutes les bandes annonces de mon site favori ne fonctionne pas

    - Firerox: tous les films fonctionnent, sauf "Çà", "Kingsman, "le sens de la fête" (c'est carrément indiqué 'désolé cette vidéo n'existe pas'), "Légo Ninjago", "seven Sisters" ('désolé cette vidéo n'existe pas', également)

    - Chrome: tous les films fonctionnent, sauf "Çà", "Kingsman", "Légo Ninjago" (que c'est 3 là)

    Sous Calculate, tout fonctionne sur Vivaldi. Sous "Namib" (basé sur Archlinux), tout fonctionne sur Vivaldi.

    J'en conclu que çà vient pas du flash, mais sans doute bien du média vidéo, mais je connais pas sous base "Debian".

    Merci à toi pour ton aide.
    Josélito
  • 12 oct. modifié
    Re. (désolé du double post, c'est pour différencier).
    je me suis rappelé qu'Adrien-D m'avait parlé du H.264. Du coup, j'ai été voir là: https://www.youtube.com/html5 .
    Effectivement, il me manque la compatibilité H.264 et MSE & H.264.
    Une piste sous Deepin ?
  • Salut Joselito,
    J'avais expérimenté ce genre de soucis avec Opera 42. J'ai modifié les liens pour tes besoins.
    Ca devrait marcher pour toi (mais à adapter selon les répertoires existants - n'ayant pas Vivaldi, je ne peux pas tester...) :
    cd /tmp
    
    # Pour 32-bits :
    wget https://repo.herecura.eu/herecura/i686/vivaldi-ffmpeg-codecs-58.0.3029.82-1-i686.pkg.tar.xz -O codecs.tar.xz
    
    # Pour 64-bits :
    wget https://repo.herecura.eu/herecura/x86_64/vivaldi-ffmpeg-codecs-61.0.3163.91-1-x86_64.pkg.tar.xz -O codecs.tar.xz
    
    # Extraction et déplacement de ffmpeg :
    tar xf codecs.tar.xz
    sudo mv ./usr/lib/opera/lib_extra/libffmpeg.so /opt/vivaldi/lib/libffmpeg.so





  • Salut Jinkobi. +1 !!

    Excellent, merci bien. J'ai pu regarder la bande annonce de Sisters Sevens. I like it. (reste tout de même 2 bandes annonces qui s'ouvre pas, même sur les autres navigateurs, donc concluant pour moi).

    Cordialement,
    Josélito
  • Pas de soucis. Content que ça ait marché ! :)
    Je garde cette astuce sous le coude, on va la mettre en ligne à terme car d'autres en auront sans doute besoin. Car c'est également la même problématique sous Opera.
  • Petite précision, après extraction du fichier, j'ai copier-collé le " libffmpeg.so " dans " / opt / vivaldi / lib " à la main en fenêtre root.
    La version actuelle de vivaldi est 1.9 (version dépôt Deepin). j'ai fais le test avec la version .deb de vivaldi (1.12), çà marche pareil.
Connectez-vous ou Inscrivez-vous pour répondre.