[FIX] Erreur de paquet suite à upgrade deepin

Bonjour a tous,

Suite à la mise-à-jour de deepin de 15.3 vers 15.4 (ou 15.4.1), je me suis retrouvé avec 2 paquets en erreurs.
Conclusion... des messages d'erreurs à chaque utilisation du gestionnaire de paquet .

Ennuyant, mais nous allons voir comment réparer cela. 

Tout d'abord déterminons que nous ayons la même erreurs: 
sudo dpkg --configure -a



En regardant de plus prêt, deux paquets sont en erreur.
Voyons ce qu'il en retourne : 
dpkg -l |egrep 'bsd-mailx|exim4-daemon-light'
iU  bsd-mailx                                     8.1.2-0.20160123cvs-3               amd64        simple mail user agent
iF  exim4-daemon-light                            4.89-1                              amd64        lightweight Exim MTA (v4) daemon

Apres vérification, ces paquets ne sont pas nécessaire au bon fonctionnement du système. 
Je me permet donc de faire du nettoyage : 
sudo apt-get remove exim4-daemon-light bsd-mailx

Et il nous reste plus qu'a remettre a jour notre distribution pour s'assurer que tout vas bien : 
sudo apt-get update && sudo apt-get -y upgrade 
sudo apt-get -y autoremove

Voilà.

Commentaires

  • 30 août modifié
    Salut!

    1. # Petit clein d'oeil:
    2. lobo@lobo-PC:~$ PS1='CouCou@KaYoo:~$ '

    3. # Version de la release:
    4. CouCou@KaYoo:~$ lsb_release -a
    5. No LSB modules are available.
    6. Distributor ID: Deepin
    7. Description: Deepin 15.4.1
    8. Release: 15.4.1
    9. Codename: unstable

    10. #  dpkg --configure aucun retour d'erreur:
    11. CouCou@KaYoo:~$ sudo dpkg --configure -a
    12. [sudo] Mot de passe de root : 

    13. # Bon, essayons d'afficher les paquets
    14. CouCou@KaYoo:~$ dpkg -l |egrep 'bsd-mailx|exim4-daemon-light'

    15. # rien ne s'affiche, peut-être une recherche which ou find:
    16. CouCou@KaYoo:~$ sudo which bsd-mailx
    17. CouCou@KaYoo:~$ sudo which exim4-daemon-light
    18. CouCou@KaYoo:~$ sudo find -name bsd-mailx
    19. CouCou@KaYoo:~$ sudo find -name exim4-daemon-light

    Comme tu peux le voir je n'ai aucun retour sur les diverses commandes, tu es sûr que le paquet est présent de base dans la release ?

  • J’apprécie le clin d'oeil !

    Donc il est normal que tu n'ai rien de présent... 
    Ce bug n'est présent qu'après une mise-a-jour de 15.3 > 15.4 !

    Ces paquets anciennement présent en 15.3 ne sont plus nécessaire et générait cette erreur. 
    Si tu as installé directement Deepin15.4 (ou 15.4.1) alors tu n'as pas a t'en soucier.

  • Ok merci de ta réponse. Je m'en doutais un peu mais je voulais être sûr.
  • Salut,

    Merci beaucoup pour ton aide Kayoo!
    Tout marche :)
    Sauf... Abode Air
    Ce n'est pas important mais je préfèrais signaler l'erreur.
  • ha comme il était déja installé avant que je mette a jour mon système.
    Je regarderai des que je peux ^^ 
Connectez-vous ou Inscrivez-vous pour répondre.