Pilote linux pour carte wifi Realtek RTL8723BE PCIe Wireless Network Adapter

Si comme moi vous avez cette carte wifi, suite à l'installation de deepin ou de n'importe quelle distri linux, le wifi ne fonctionnera plus (ou mal).
Pas de panique, nous allons voir ici comment résoudre le problème.

Tout d'abord, vérifions bien qu'il s'agit de la même carte en demandant les infos matérielles concernant le réseau:
lspci | grep "Network"
La commande doit vous renvoyer:
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
C'est le cas? Super! Votre problème sera réglé d'ici peu.

Il y a deux problèmes identifiés avec cette carte wifi, le premier, c'est qu'elle a tendance à se mettre en veille aléatoirement. Pour le corriger, ,il suffit de l’empêcher de se mettre en veille:
echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf
Et on recharge le module:
sudo modprobe rtl8723be
A ce stade, il est possible que votre problème soit réglée. Si ce n'est pas le cas et que votre problème revient (parfois plusieurs jours après) c'est que votre ordinateur  utilise le mauvais module. Pour y remédier nous allons donc compiler ces modules afin de les remplacer par ceux utilisés par défaut par votre noyaux.
Afin de poursuivre le tuto, une connexion filaire est nécessaire.

1. Installer git pour pouvoir télécharger sur github:
sudo apt-get install git
2.Le paquet linux-headers-generic, qui nous permet de compiler des modules personnalisés:
sudo apt-get install linux-headers-generic build-essential dkms git
3.On télécharge les sources du dépôt:
git clone https://github.com/lwfinger/rtlwifi_new.git
On se place dans le répertoire:  
cd rtlwifi_new
4.Puis on compile et on installe les modules:
make all
sudo make install
sudo modprobe rtl8723be

Pour finir, on configure notre module afin:

1. Empêcher la mise en veille:

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

2. Régler le module sur antenne 1 ou antenne 2. 

Nous ne pouvons pas savoir à l'avance laquelle des deux fonctionnera, il faut donc essayer les deux (chez moi c'est l'antenne 2 qui fonctionne). Par défaut le module est réglé sur antenne 1. 

Pour basculer sur l'antenne 2:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

une fois que vous avez trouvé la bonne antenne, rendez l'option persistante.

A titre d'exemple pour rendre persistant l'option antenne 2:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Si vous n'êtes pas sur de quelle antenne choisir (mais logiquement c'est flagrant puisque le wifi se mettra à fonctionner normalement) vous pouvez tester leur signal comme ceci:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=1
sudo iw dev wlan0 scan | grep signal
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2
sudo iw dev wlan0 scan | grep signal

B) ENJOY! B) 


Tuto réalisé en compilant des informations de plusieurs topik ubuntu-fr ainsi que du blog d'Angristan, merci à Kayoo pour son aide et pour l'apport d'information concernant le choix de l'antenne qui fût déterminante pour débloquer ma situation.

«1

Commentaires

  • 21 août modifié
    Merci pour ce tuto :) 
    Clair, simple, instructif => J'aime ! 

    Je rajoute que ce module est compatible avec les cartes wifi suivante : 
    rtl8192ce, rtl8192se, rtl8192de, rtl8188ee, rtl8192ee, rtl8723ae, rtl8723be, and rtl8821ae.


  • 21 août modifié
    Merci Kayoo.
    Je rajoute que ce module est compatible avec les cartes wifi suivante : 
    rtl8192ce, rtl8192se, rtl8192de, rtl8188ee, rtl8192ee, rtl8723ae, rtl8723be, and rtl8821ae.
    En effet! Car la Source github utilisé compile en fait plusieurs modules.
    https://github.com/lwfinger/rtlwifi_new

    Je voulais le préciser mais j'avais peur de surcharger. Merci d'avoir ajouter l'info en message car ainsi il est possible que des personnes rencontrant des problèmes avec les autres cartes le retrouve en recherche dans google.

    J'ai aussi hésité de proposer un tuto complémentaire pour y arriver sans connexion filaire à partir d'un autre pc  mais j'ai peur de surcharger et compliquer pour rien.
  • c'est très bien comme ca ^^ 
    encore merci pour ton investissement...
  • C'est la moindre des choses...
    Dommage que je n'ai pas eu l'occasion de le proposer avant car je pense que ça aurait réglé le problème de Phoeby. Il est aussi possible que le soucis bluetooth d'Heolys85 soit quelque chose qui ressemble à ça.
  • coucou la communauté Deepin  :)

    J'avais les mêmes problèmes mais avec une autre carte wifi , coupures, lenteurs, inactivité...  Bref c'était pénible... 
    J'ai suivi la première partie de Lobo1512 qui explique ce phénomène par la mise en vieille auto de la carte wifi.

    lspci | grep "Network"
    01:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)1

    puis j'ai remplacé par mon matériel qui BCM43124

     echo "options BCM43142 fwlps=0" | sudo tee /etc/modprobe.d/BCM43142.conf
    options BCM43142 fwlps=0

    Merci beaucoup tout le monde pour les solutions proposées

  • Bonjour,

    Comment est-il possible de rendre perenne à la fois le blocage de la mise en veille et le choix d'une antenne ? Car quand je tape une commande pour pérenniser le choix de l'antenne ça me supprime le pérennisation du blocage de la mise en veille et inversement.

    Je suis grand débutant sur linux.

    Merci par avance pour la réponse.
  • c'est assez étrange... Il n'y a pas de rapport entre la mise en veille et le driver wifi.
    Les options de mise en veille sont présente directement dans les options du deepin Center
  • 26 sept. modifié
    @kayoo
    Ici Labo1512 parle de la mise en veille de la carte wifi pas de celle de l'ordinateur.
    @wanou
    La commande tee écrase le fichier existant, pour écrire la 2eme option sans écraser le fichier il faut utiliser tee avec le paramètre -a (--append).Par exemple:
    echo "options rtl8723be ant_sel=2" | sudo tee -a /etc/modprobe.d/rtl8723be.conf
  • effectivement je mélange tout ^^
  • Précision sur le tuto
    Après mise à jour de la distrib (passage à la 15.4.1) je me suis rendu compte que le problème revient, en fait il fallait juste basculer sur l'autre antenne (dans mon cas la 1ere)

    @wanou
    Tu peux essayer ça sinon (comme ça tu écrases avec les 2 options en même temps)
    echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf
    sudo modprobe -r rtl8723be
    sudo modprobe rtl8723be

Connectez-vous ou Inscrivez-vous pour répondre.