Statut des paquets.

Bonjour,
Je ne suis pas encore familier aux commandes Debian, lors d'une mise à jour d'une Deepin de test sur une machine virtuelle je reçois le message suivant:
dpkg: erreur de traitement du paquet gstreamer1.0-plugins-ugly:amd64 (--configure) :
 le paquet est dans un état vraiment incohérent; vous devriez
 le réinstaller avant de tenter de le configurer.
dpkg: des problèmes de dépendances empêchent la configuration de miraclecast :
 miraclecast dépend de gstreamer1.0-plugins-ugly ; cependant :
 Le paquet gstreamer1.0-plugins-ugly:amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet miraclecast (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 gstreamer1.0-plugins-ugly:amd64
 miraclecast
E: Sub-process /usr/bin/dpkg returned an error code (1)

Le message est clair me direz-vous mais je préfère demander avant.


Quand je demande le statut de gstreamer1.0-plugins-ugly j'ai ceci:

tatou@deepin-virt:~$ sudo dpkg-query -l 'gstreamer1.0-plugins-ugly*'
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                       Version           Architecture      Description
+++-=========================-=================-=================-=======================================================
iUR gstreamer1.0-plugins-ugly 1.10.4-1          amd64             GStreamer plugins from the "ugly" set

Comment interpréter les iUR?

Merci pour toute aide.


Commentaires

  • Comme je m'en doutais il fallait réinstaller gstreamer-1.0-plugins-ugly et reconfigurer  miraclecast, c'est ce que j'ai fait et cela a résolu le souci.
    Comment interpréter les iUR?
    A cux qui se poseraient la même question il faut savoir que
    - la premiere letrre  correspond au souhait
    - la deuxième letrre  correspond au l'état
    - la troisième letrre  correspond a l'erreur
    ensuite on suit la légende.

    Dans le cas de gstreamer-1.0-plugins-ugly:
    -  première lettre i : Souhait=installé
    - deuxième lettre U; Statut=dépaqueté
    - troisième lettre R: Erreur= nécessite une réinstallation.







  • Tatou, 

    Même pas le temps de finir me weekend que tu as déjà trouvé solution.
    Merci pour le partage. 
    C'est une très bonne initiative de commenter et d'expliquer la résolution. 

    Que ca serve tout-a-chacun ;)
Connectez-vous ou Inscrivez-vous pour répondre.