Après installation Deepi écran noir

Bonjour à tous,

J'ai découvert en juin la distrib Deepin, après plusieurs tentative d'installation sur un disque dur 5400 tr je me retrouver toujours dans le même cas après de reboot de la fin d'installation, je lance deepin et hop écran noir et voir même éteint ou comme si il ne recevait plus de signal de la carte graphique.

D'ailleurs pour l'installation je devais choisir le live cd, car l'installation classic me donner le même résultat ci dessus.

Voici la config de mon pc :

Processeur : I7 860 
Ram : 20 go DDR3
Carte mère : Asus P7P55D
Carte graphique : Asus STRIX 950 GTX 4 GO
Disque dur pour l'installation : 2 pouce et demi 5400 tr 250 go

Voilà pour la config, j'ai tester plusieurs solution dvd et clef usb, toujours le même problème.

J'ai tester sur virtualbox est la sa fonctionne.

Je me souviens de certaine distribution linux merder avec nvidia, auriez-vous parmis la communauté rencontrer le même problème ?

J'espère que vous aurez une solution.

j'ai tester sur deepin 15.4 et  15.4.1 

Merci à tous d'avance.
«13

Commentaires

  • Salut Nicovapp, 

    C'est une jolie config que tu as là ^^ 
    Par contre, ca ressemble bcp a un problème de drivers de ta CG.

    Peux tu démarrer ta session et sur l'écran noir basculer sur un terminal (CTRL + ALT + F2)
    tu t'identifies (login / pass) 

    Tu passes en root et tu installes le paquet manuellement : 
    sudo -i
    apt update
    apt install nvidia-driver
    Tu suis les étapes et tu reboot.
  • salut Kayoo,

    merci de ta reponse, je n'ai pas précisé dans mon post original que j'avais déjà essayé cette méthode, mais mon ecran est en mode " je ne detecte pas ta carte".

    comme tu me le dit c'est bien un problème de pilote, mais je n ai aucun moyen de le mettre a jour autrement ? depuis le live cd vers mon installe en ligne de cmd?

    merci de ta reponse en tous cas ;-)
  • 25 juil. modifié
    Normalement en basculant sur le TTY, tu dois etre capable de voir une console (sans support de ta CG) 

    Pour faire ce que tu dis, il faudrait booter sur un live CD, monter les paritions de ton systeme, chrooter l'environnement et faire une installation du drivers.... 

    Mais je vais avoir bcp de mal a te guider dans ce process que je connais que trop peu.

    As-tu essayé de démarré en mode SINGLE ? 
    Au démarrage, lors de l'écran de boot, press la touche "e" et ajoute "S" a la fin de la ligne sur le kernel. 
    Ca devrait etre suffisant pour démarrer en single-mode.

    Je fais le test chez moi si c'est pas clair et te donnerai un meilleur procédure ^^ 
  • Super je te remercie, j'ai essayer tous ça demain ou ce week end je pense (j'ai reçu mon ssd pour installl windob 10).

    ta solution du live CD et de monter la partitions j'ai déjà essayer mais pas encore assez caler sur la chose ^^.

    merci en tous cas de ton aide.
  • Salut à tous ,
    J'ai tester de démarré en mode SINGLE avec les touches e et s comme Kayoo me l'avais suggéré, je suis donc tombé sur GRUD.
    Est là du coup j'étais un peu perdu, mais j'ai au moins un espoir de pouvoir mettre à jour ou de lancer deepin.

    Il me reste plus cas chercher comment fonctionne GRUD ^^

    Merci en tous cas et si quelqu'un à une idée je suis toujours à l'écoute.
  • 21 août modifié
    Installer driver pour GTX 950:
    Manip que j'ai trouvé ici et que j'ai légèrement modifié pour tout faire dans le terminal.
    Je n'ai pas testé. A prendre avec des pincettes!
    Ceci dit si tu n'as rien de plus qu'un écran noir tu n'as pas grand chose à perdre je pense... Alors peut-être ça vaut le coup d'essayer.

    télécharger le driver:
    wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/384.59/NVIDIA-Linux-x86_64-384.59.run

    Le rendre exécutable:
    chmod +x ./Downloads/NVIDIA-Linux-x86_64-384.59.run

    Mise à jours et prérequis:
    sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade && sudo apt-get install build-essential && sudo apt-get install linux-source && sudo apt-get install linux-headers-generic

    Editer le grub
    sudo nano /etc/default/grub
    ou
    sudo vi /etc/default/grub

    Remplacer la ligne: (ça devrais forcer le graphisme bas niveau pour éviter l'écran noir, du coup vu que j'ai modifié la manip pour tout faire dans le terminal je suis pas sur que ça soit utile, mais bon, ça peut pas faire de mal et on sait jamais, et de toute façon à la fin on reviens sur la config d'origine. J'ai aussi modifié la ligne à remplacer car dans deepin elle est légèrement différente)
    GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"
    

     Par:
    GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash nomodeset"

    sauvegarde et quitte:
    ctrl+o && ctrl+x si tu as utilisé nano
    :wq si tu as utilisé vi

    On lance la config:
    sudo update-grub2

    désinstallation des drivers nvidia:
    sudo apt-get remove nvidia* && sudo apt-get autoremove

    On redémarre
     sudo reboot 

    Réouvre le terminal puis:
    sudo nano /etc/modprobe.d/blacklist.conf
    ou
    sudo vi /etc/modprobe.d/blacklist.conf

    Rajoute les lignes suivantes à la fin:
    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    blacklist lbm-nouveua
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off

    On stoppe la session graphique:
    sudo service lightdm stop

    On rentre dans le répertoire:
    cd ./Downloads

    On lance l'exécutable:
    sudo ./Downloads/NVIDIA-Linux-x86_64-384.59.run

    On redémarre:
    sudo reboot

    On édite:
    sudo nano /etc/default/grub
    ou
    sudo vi /etc/default/grub

    Remplace:
    GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash nomodeset"
    Par
    GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"

    Sauvegarde et quitte:
    ctrl+o && ctrl+x
    ou
    :wq

    On charge la config:
    sudo update-grub2

    On redémmare:
    sudo reboot

  • Kayoo si tu passes par là je veux bien ton avis sur la manip.
    Je l'ai donné sans pouvoir tester ni être sur du résultat car à mon avis ça peut pas être pire qu'avoir un écran noir... Donc dans ce cas particulier je pense que ça vaut le coup d'essayer et donc de la donner même sans être certain.
    Cependant si elle pouvait être relu par quelqu'un de plus compétent que moi ça serait bien aussi...
    Merci d'avance.
  • salut et merci, je viens de lire ton post en diagonale et j'ai juste une info a te donné.
    je n ai pas accès au terminal classic, je suis sur GRUD, donc pas accès au commande classic linux, je testerai pas tous de suite de toute façon.

    merci vraiment en tous cas.
  • Le soucis avec les pilotes Nvidia proprio c'est d'installer ca sans l'interface-graphique (c'est un prérequis).
    Et pour un néophite c'est pas facile. 

    Sinon je ne vois rien a redire sur la procédure... elle reste classique sur l'installation du pilote Nvidia.

    @nicovapp
    Concernant gruB, il s'agit d'un micro-systeme installé sur la toute première partition (appelé partition d'amorcage) qui gère l’ordre de démarrage de tes disques. 
    Ce n'est donc pas normal que tu démarres et que tu restes coincé sur celui-ci...

    As-tu un message, ou une photo, a nous donner ? 
  • salut Kayoo, je vais te faite sa dans 2 semaine sans problème.

    merci pour tous ;-)
Connectez-vous ou Inscrivez-vous pour répondre.