Problème de taille de police

Salut
J'ouvre comme convenu un nouveau poste concernant mon souci sur Deepin.
Le lien de mon commentaire: http://forum.deepin-fr.org/discussion/comment/1044/#Comment_1044

Pour répondre à ta question Kayoo; oui j'ai fait l'installation de mes drivers. Et en faite, c'est à la suite d'avoir installer les pilotes GPU et CPU que tous cela c'est produit.
La police était correcte de partout puis après l'installation des 2 pilotes, je ne pouvais plus distingué quoique ce soit à certain endroit tellement c'était trop petit.
Un screen serait plus parleur je pense; 

CPU: Intel i7 7700k
GPU: PNY - GeForce GTX 1060 6GB

Question à part; Avez-vous ou envisagez-vous d'avoir un Discord ?

Merci de votre écoute. ^^

«1

Commentaires

  • Salut YouMe, 


    Dejà :) j'adore ton panda !!! 

    Quel soucis ? moi je vois très clairement ce qui est écris, pas vous ? 
    Hahaha en fait non pas grand chose...

    Ensuite, j'ai été pas mal occupé ce weekend donc pardonne mon délais de réponse.
    Comme je l'ai présumé, il s'agit bien du driver de ta carte graphique qui est mal géré.
    C'est souvent le cas sur les dernières CG, et c'est bien ton cas ^.^
    (Au passage, très belle config, je suis jaloux)  :s

    Déjà, as-tu essayer de décocher les 2 pilotes que tu as installé et redémarré ? 
    Si ca ne corrige pas, on ira un peu plus loin ^^


    BTW: le discord a été initié il y a longtemps de cela. 
    Le sujet est en standby sur son maintiens ou non... 
    Tu peux venir y faire un tour.. mais je suis seul pour le moment :p 
    https://discord.gg/aDUp5nB



  • Re Kayoo,

    Tu m'as bien fait peur. Je suis aller revisionné mon screen pour voir si ce n'était pas moi qui avait un problème de vue. Je n'avais pas fini de lire le reste du message. Hhhh 

    Et pas de souci pour le délais de réponse. J'ai beaucoup de patience; bien qu'il m'est arrivé de penser migré sur Manjaro Deepin, histoire de voir si j'avais le même souci. Mais je préfère attendre un retour, vu que j'ai pris la peine de vous solliciter.
    Elle n'est pas si foufou que ça la 1060, en tout cas sous Windows. (Il y a 2GB qui errent dans le néant).
    J'ai cru comprendre qu'Nvidia n'arrivait pas à géré la totalité de la mémoire vidéo de ces cartes graphiques sous Windows mais sous Linux tous est exploité à 100%. Ou j'ai mal compris.
    Enfin je m'écarte du sujet. Héhé :#

    Quand tu parles de décocher, c'est de revenir aux drivers par défauts (les opens sources) ?
    Je l'ai fait tantôt, après avoir lu ton message, que la GPU. Effectivement ça règle le souci, mais je vais être limité avec ma GPU. Je ne peux pas changé la résolution de l'écran 1024x600, si je ne dis pas de bêtise.

    Après ça aurait été bien de pouvoir agrandir la taille de la police au delà de sa limite maximale quand j'ai le drivers installer.
    Cela peut il se faire ? :s

    Essaye de mettre Discord en avant sur le forum, pour que les autres puissent y faire un tour. ^^


    Merci encore pour ton aide.
    See you again desu !

                                   


  • Les drivers open-sources sont géré par la communauté linux pour apporter une compatibilité de ton équipent.
    Ils sont loin d’être optimisé que les version proprio, donc tu peux faire une croix sur la toute dernière techno de ta carte, mais il ont le luxe de fonctionner à 90% :) Là où les versions proprio ne sont pas compatible avec tous les systemes... 
    Les constructeurs ne jouent pas tous le jeu ... et je passerai les pots de vin pour que certain OS soit favorisé (suivez mon regard...)

    Donc il faut savoir : 
    - Driver opensource : fonctionne à 90% mais suffisant pour le commun des mortels 
    - Drivers Proprio : si il marche tant mieux, sinon tu risques de rencontrer d'autre soucis (comme la police des caracteres).

    Car effectivement pour ton soucis, je doute qu'il s'agisse d'une histoire de taille de caractère... C'est bel et bien ton drivers proprio qui fait des siennes. Et comme, le code est fermé, on va pas pouvoir y faire grand chose ^^

    Pour la petite histoire, Linux s'en sort royalement sur le support d'ancienne CG mais les dernières tendances n'arrive qu’après quelques années :) 

    Par contre, ce n'est pas normal que cela baisse ta résolution à du 1024.
    Pourrais-tu nous donner le retour de cette commande : 
    xrandr -q


    EDIT: J'ai recherché un peu ta GPU est normalement bien compatible avec Linux ! 
    Donc on va aller plus loin pour la faire fonctionner .

    0. Fait un rapide sauvegarde des choses que tu ne souhaites pas perdre (on ne sait jamais)

    1. Liste nous les paquets qui ont déja été installé !
    dpkg -l |grep nvidia

    Si certain paquet sont existant il va falloir les purge : 
    apt purge nvidia*

    2. Installation de driver propriétaire NVIDIA
    cd /tmp
    wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/375.66/NVIDIA-Linux-x86_64-375.66.run
    sudo chmod +x NVIDIA-Linux-x86_64-375.66.run
    sudo ./NVIDIA-Linux-x86_64-375.66.run
    sudo reboot
    Récupération depuis le site officiel : http://www.nvidia.fr/download/driverResults.aspx/118433/fr

    Penses également désactiver le "secureboot" dans ton BIOS :) 


    Tiens nous au courant.

  • Salut...
    Désolé de répondre en retard.
    Je vais m'effectué tes indications dans pas longtemps.
    Ca va prendre un peu de temps avec toutes ses nouvelles informations (qui me sont quelque peu inconnues). s:

    En tout cas merci pour ton aide très appréciée. ^^
             
  •  Commande: xrandr -q
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected 1024x768+0+0 0mm x 0mm

    Les paquets qui sont ou ont été installés !
    rc  glx-alternative-nvidia                   0.7.2+deepin2                        amd64        allows the selection of NVIDIA as GLX provider
    ii  libgldispatch0-nvidia:amd64              375.26-1+deepin                      amd64        Vendor neutral GL dispatch library -- libGLdispatch
    ii  libgldispatch0-nvidia:i386               375.26-1+deepin                      i386         Vendor neutral GL dispatch library -- libGLdispatch
    ii  libnvidia-eglcore:amd64                  375.26-1+deepin                      amd64        NVIDIA binary EGL core libraries
    ii  libnvidia-eglcore:i386                   375.26-1+deepin                      i386         NVIDIA binary EGL core libraries
    ii  libnvidia-glcore:amd64                   375.26-1+deepin                      amd64        NVIDIA binary OpenGL/GLX core libraries
    ii  libnvidia-glcore:i386                    375.26-1+deepin                      i386         NVIDIA binary OpenGL/GLX core libraries
    ii  libopengl0-glvnd-nvidia:amd64            375.26-1+deepin                      amd64        Vendor neutral GL dispatch library -- libOpenGL
    ii  libopengl0-glvnd-nvidia:i386             375.26-1+deepin                      i386         Vendor neutral GL dispatch library -- libOpenGL
    rc  nvidia-alternative                       375.26-1+deepin                      amd64        allows the selection of NVIDIA as GLX provider
    rc  nvidia-driver                            375.26-1+deepin                      amd64        NVIDIA metapackage
    ii  nvidia-egl-common                        375.26-1+deepin                      amd64        NVIDIA binary EGL driver - common files
    ii  nvidia-installer-cleanup                 20151021+4                           amd64        cleanup after driver installation with the nvidia-installer
    ii  nvidia-kernel-common                     20151021+4                           amd64        NVIDIA binary kernel module support files
    rc  nvidia-kernel-support                    375.26-1+deepin                      amd64        NVIDIA binary kernel module support files
    ii  nvidia-legacy-check                      375.26-1+deepin                      amd64        check for NVIDIA GPUs requiring a legacy driver
    ii  nvidia-modprobe                          367.44-1                             amd64        utility to load NVIDIA kernel modules and create device nodes
    ii  nvidia-persistenced                      367.57-1                             amd64        daemon to maintain persistent software state in the NVIDIA driver
    rc  nvidia-settings                          343.36-2                             amd64        tool for configuring the NVIDIA graphics driver
    ii  nvidia-support                           20151021+4                           amd64        NVIDIA binary graphics driver support files
    ii  nvidia-vulkan-common                     375.26-1+deepin                      amd64        NVIDIA Vulkan driver - common files
    rc  xserver-xorg-video-nvidia                375.26-1+deepin                      amd64        NVIDIA binary Xorg driver

  • Je n'arrive pas à purger les packages existants car soit disant je ne suis pas un "Superutilisateur".
    J'ai effectué la commande "su" puis entré mon mot de passe qui à par la suite échoué. u_u

    J'ai un autre problème également. Je n'ai aucun son sortant. Mais ça ça doit être du au faite que mes pilotes soient en Open Source ? o:

    Pourquoi désactivé le sécureboot ?

    PS: Désolé pour la multitude de postes.
    J'ai eu du mal avec la seconde commande qui m'empêchait d'écrire autre chose après.
  • 30 mai modifié
    Je n'arrive pas à purger les packages existants car soit disant je ne suis pas un "Superutilisateur".

    Il faut exécuter la commande en superutilisateur, donc:

    sudo apt purge nvidia*
    @Kayoo: je me demande s'il ne vaut pas mieux faire un "sudo apt purge *nvidia*"

  • 30 mai modifié
    Ne pas oublier aussi de supprimer ou renommer xorg.conf.
    Avant de réinstaller le pilote Nvidia  reboot pour voir si l"affichage est correct avec le pilote nouveau (intégré au kernel).
    Si j'ai bien compris, l'affichage était correct avant l'installation des pilotes Nvidia. Dans ce cas la suppression des paquets nvidia et de xorg.conf te permet de revenir à la configuration initiale.
  • 30 mai modifié
    Salut Tatou.

    J'étais repassé en mode pilote OS. L'affichage à pu ce rétablir sans renommer quoi que ce soit. Par contre le souci avec le pilote OS, la seule résolution qui m'est possible d'afficher sur mon écran est 1024x768.
    Avec le Driver Nvidia je peux passé en 720p ou 1080p mais le soucis c'est que l'affichage de la police d'écriture devient très base donc illisible. La taille max c'est x16 pour la police je crois.

    Re:

    J'ai en effet réussie à faire la purge des packages avec ta commande.
    Donc "Sudo" devant une commande c'est pour désigné le mode "Superutilisateur" ?

    @kayoo : Voilà ce que l'installation m'a donné en retour. :/

    ERROR: You appear to be running an X server; please exit X before 
             installing.  For further details, please see the section   
             INSTALLING THE NVIDIA DRIVER in the README available on    
             the Linux driver download page at www.nvidia.com.
  • Re:

    J'ai essayé toutes les installations possibles, (ta commande et même dl directement le pilote .run en essayant la commande "cd" depuis le terminal mais tout fail). u_u

  • Le message d'erreur dit que tu ne peux pas exécuter le .run quand le serveur X tourne, donc tu dois booter en init 3 pour exécuter le .run.
  • Excuse moi, mais pourrais tu m'expliqué en détaille, étape par étape pour faire l'exécution du .run en boot init 3 ?
  • Salut YouMe, ^^ 

    alors je vais essayer de répondre a quelques-une de tes questions : 
    - sudo, c'est effectivement pour donner des droits "superutilisateur" (un peux comme les droits admins) de la commande qui va suivre. Pour supprimer des paquets tu as effectivement besoin de droits plus élevé.

    - Tatou, a raison, il vaux mieux purger tous les paquets nvidia avec la commande : 
    sudo apt purge *nvidia* 
    Même si les librairies sont des dépendances et seront également retiré 

    - En effet, il est bon de sauvegarder la configuration de son serveur X, (Pour info le serveur X ou Xorg, c'est le process qui gere la couche graphique de ton système) 
    Pour en faire une sauvegarde :
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    Il est régénéré mais c'est toujours bon de sauvegarder ce que l'on fait :) 

    - Ensuite pour ton message d'erreur lors de l'execution du script du drivers propriétaire Nvidia, il faut couper ton serveur X car il va l'écraser. Le plus simple est de bascule dans un autre mode de démarrage (appelé init ou runlevel) 
    Par defaut, on utilise le runlevel5, qui démarre ton PC comme tu le connais, avec ta cartegraphique, le reseau, etc... 
    Ici, pour l'occasion, on vas démarrer en runlevel3, qui va démarrer tous les process sauf le mode graphique. 

    Attention les commandes suivantes vont te faire perdre l'afficheage de ton PC, alors essaye d'ouvrir la page sur ton téléphone ou écris les commandes suivantes sur un papier. 

    Avant toute chose, sache que si tu décide de redémarrer ton ordinateur, tu relanceras le mode graphique (runlevel5)


    1. Re-télécharge le driver si ils ne sont plus présent
    cd /tmp
    wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/375.66/NVIDIA-Linux-x86_64-375.66.run
    sudo chmod +x NVIDIA-Linux-x86_64-375.66.run
    2. bascule sur le runlevel3
    sudo init 3
    cd /tmp
    ls 
    sudo ./NVIDIA-Linux-x86_64-375.66.run
    sudo reboot
    

    3. si tout vas bien c'est parfait, sinon tu peux jouer avec la configuration de ton driver avec : 

    sudo nvidia-xconfig


    bonne chance :) 

  • Il y a une petite difficulté supplémentaire à laquelle tu devras te préparer, quand tu seras en init 3 tu te retrouveras avec un clavier qwerty. J'ai pas trouvé le moyen de le basculer,, ni "loadkeys fr" ni "setxkbmap fr" ne marche.
    Alors imprime une feuille avec la disposition des touches sur un clavier qwerty avant.
  • chut c'est la surprise ^^
    Il faut que je trouve un moyen d'embarquer le clavier "azerty"...
  • ENNNNNFINNNN... J'y suis arrivé !!

    (Chose que j'aurais réellement voulu dire en arrivant sur le forum).


    Sinon salut vous deux.
    J'ai passé toute ma soirée sur cette commande en init 3, et vraiment désolé mais je n'y arrive pas. ^^
    L'affichage passe bien en fond noir avec l'underscore clignotant en haut à gauche de l'écran, mais.... mais je n'arrive à rien avec cet écran. Je peux ni écrire ou ni voir ce que j'écris.
    Après peut être que c'est le but, écrire avec cet handicape ?!
    Je croyais que le seul handicape de cette manip était celui du clavier en QWERTY. 


    La commande suivante devrait être effectuée en une étape ou plusieurs ?
    sudo init 3
    cd /tmp
    ls 
    sudo ./NVIDIA-Linux-x86_64-375.66.run
    sudo reboot

    Dès que je la lance elle est censée exécuter l'installation ou il faut que j'écrive quelque chose sur l'affichage noir/underscore ?
    Si j"écris juste "sudo init 3" sans le reste, il me redire sur l'affichage également. Donc "cd /tmp" et etc sont ceux que je dois écrire ? 


    Bien dommage que ce soit si compliqué d'installer un driver sur ce petit bijoux.

    Bonne journée ou soirée à vous. ^^
  • Content que tu aies résolu ton souci.
    Bien dommage que ce soit si compliqué d'installer un driver sur ce petit bijoux.

    Il faut dire que tu es tombé sur une exception.

    Si les fabricants de matériel jouaient le jeu on n'en serait pas là.

    @Kayoo: j'ouvrirai un autre fil à propos de vconsole keymap pour ne pas polluer celui-ci.

  • Salut, youMe, 

    Comme le dit Tatou, tu es une exception, le gestionnaire de drivers est sensé te faire cela automatiquement.
    Il marche 90% du temps ^^
    J'espere que d'utiliser leur script va faire que ca ira mieux et que tu n'auras plus de petite police...

    C'est tout a fait normal que l'init3 te sort un ecran noir.
    Par contre, ce n'est pas normal que tu n'es pas de message d’accueil ou d'invitation a te connecter avec ton login...

    Sinon, tu peux toujours basculer sur un TTY sans le support de ta carte graphique. 
    - Démarre ton PC  (logique)
    - après t’être connecté il te suffit d'utiliser les commandes suivantes :  CTRL + ALT + f2
    - Ca ne ferme pas le serveur X, mais je pense que ca devrait suffir pour l'installation de ton drivers.
    - Une fois sur l'ecran noir, il te demandera ton login et ton mdp (a renseigner 2 fois sans qu'il ne s'affiche)
    - il te rendra la main et tu pourras enfin réalisé les commandes : 
    cd /tmp
    wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/375.66/NVIDIA-Linux-x86_64-375.66.run
    sudo chmod +x NVIDIA-Linux-x86_64-375.66.run
    sudo ./NVIDIA-Linux-x86_64-375.66.run sudo reboot
    - Si tu veux revenir en mode graphique : CTRL + ALT + f7

  • 1 juin modifié
    Salut

    Me revoilà avec un retour sur cette dernière commande 
    Désolé pour la qualité de la photo, je ne pouvais pas faire mieux.

    Je ne comprend pas pourquoi ça capote toujours. u_U

    Pour revenir sur la précédente commande "init 3". Peut être me manque t-il un pré-requis pour pouvoir effectué la commande et voir l'affichage. Je vois bien le logo Deepin dans le fond en effet mais je ne peux rien écrire ceci dit ?!



  • 1 juin modifié
    Re:

    Petit retour sur la commande "init 3". 
    Je pense avoir réussi à accéder au bonne affiche pour pouvoir écrire dans ce mode. 
    Pour moi il fallait la couplé avec le raccourci "CTRL+ALT+F2" puis effectuer la commande "sudo init 3".
    Après je ne sais toujours pas si la suite sera prometteuse. 

    Pourriez vous me confirmer si c'est l'affichage que je devrais avoir ? 

  • 1 juin modifié
     Re: C'est encore moi !

    1. Mon premier essai avec la commande plus haut.
    J'ai donc effectivé l'entrée en "CTRL+ALT+F3". J'ai par la suite entré mes logs, puis je suis allé directement en mode "init 3".
    J'ai donc entrer les précédentes commandes que tu m'avais fournie, Kayoo.

    cd /tmp
    ls 
    sudo ./NVIDIA-Linux-x86_64-375.66.run
    sudo reboot
    Mais aucun fichier exécutable n'a été trouvé.
    Du coup j'ai tenté de la DL depuis le mode "init 3". Mais semble que la connexion ne soit pas détecté également dans ce mode.

    Pendant un instant, je me suis senti comme Balrog fasse à Gandalf.


    1. Mon second essai fut un franc succès. 8D
    J'ai donc DL le pilote depuis le raccourci "CTRL+ALT+F3" puis je l'ai installé en monde "init 3". Et résulta, je suis passé mais.... mais... mais avec le même malus de départ. En gros la police est toujours aussi petite. 
    Mais bon, je suis quand même content d'avoir pu installer le pilote. LeL

    Ça va quand même faire 1 bon mois que je cherche un bon Distro Linux, et le seul qui me plait c'est celui-ci mais c'est également le seul qui me donne autant de mal.
    Je compte même plus le nombre de fois ou j'ai du désinstaller et réinstaller des Distros juste pour voir lequel me plairait le plus.
    Ce qui est très dur, c'est également le boot des OS, qui lorsque tu veux installer un autre en supprimant le Linux précédent, ça corrompt le boot de Windows 10. u_u

    Enfin bon...
    Si vous avez d'autre suggestion je suis preneur. Après s'il n'y a pas moins de régler ce souci, ce n'est pas grave.
    En tout cas merci bien pour votre patiente et aide.

    Soirée. ^^
                           
  • 1 juin modifié
    J'ai essayé d'installer le Driver suivant, mais j'ai toujours le même soucis. ^^'
    Peut être que le souci vient d'ailleurs finalement ? Mais je n'ai pas encore essayé un pilote antérieur à celui proposé par défaut.
    Mais surtout, je n'arrive pas à purgé les nouveaux pilote installer manuellement car je n'arrive pas à revenir sur le pilote OpenSource.

    1. CTRL+ALT+F3

    cd /tmp
    wget http://us.download.nvidia.com/XFree86/Linux-x86_64/381.22/NVIDIA-Linux-x86_64-381.22.run
    sudo chmod +x NVIDIA-Linux-x86_64-381.22.run
    sudo init 3

    2. Runlevel 3
    cd /tmp
    ls 
    sudo ./NVIDIA-Linux-x86_64-381.22.run
    sudo reboot

  • Bon déjà félicitation pour ta ténacité ! 

    Tu sembles interessé et c'est toujours un plus quand on travail sur des OS linux :) 

    Pour démarrer sur l'init3 je ferais quelques test ce weekend à la maison. 
    Concernant ton drivers, c'est bien ce qui me faisait peur.. on se retrouve avec le même comportement que lors de l'installation auto par l'outil "gestion des pilotes".

    as-tu essayé de lancer :
    sudo nvidia-xconfig
    Et de jouer avec quelques paramètres ? 
    On ne sais jamais si ca peut t'aider a corriger ce problème de police.


    Pour la suppression des drivers, il me semble que tu dois avoir un script pour le faire :
    sudo nvidia-uninstall

  • Bonsoir, je voudrais vous soumettre une petite suggestion pour mettre et ainsi avoir toujours le clavier en français dans les consoles de démarrage (tty...) : 

    sudo apt install console-setup

    ensuite configuration  : 

    sudo dpkg-reconfigure console-setup
    
    (27 UTF-8 ....11# latin1 et latin5 : langues de l'Europe de l'ouest et turc...7Choix automatique d'une police adaptée
    
     
    Voilà  :)  
    
    
    
    
    



  • Super! Ça marche.
    Merci pour ton retour.
  • Merci mvdp, je vais l'automatiser sur l'outil deepin-tools.

    Si vous avez d'autre astuce n'hésitez pas ! 
  • De rien avec plaisir.... :)
  • Hola tout le monde !
    Et merci pour cette petite manip Mvdp06.

    Effectivement, je le veux vraiment ce petit OS, Kayoo. Mais on dirait que ce n'est pas réciproque.
    J'ai même essayé d'installer la version précédente de Deepin, la 15.3. Mais même elle, bug. (Aucune connecté internet et des petites freeze).

    Un truc que je ne comprend pas, c'est que la version Deepin sous Manjaro, ne me pose aucun souci quand j'installe la version proprio. Le seul bémol, c'est que la personnalisation du boot sous Manjaro Deepin bug pour moi.

    J'ai testé tes commandes, et aucune d'elles ne passent. Et franchement je pense qu'effectivement ça pourrait réglé mon souci.
    Je suis allé chez nos voisins les Anglais, et vu un cas similaire. Comme par hasard, pour réglé le souci, faut effectué la commande "sudo nvidia-xconfig". Fuuuuuuh !

    Forum: https://bbs.deepin.org/forum.php?mod=viewthread&tid=139028&extra=page=4
    Redirigé: http://www.techytalk.info/lubuntu-change-fonts-dpi-when-using-proprietary-nvidia-driver/comment-page-1/

    Si t'as une solution pour que je puisse faire cette commande ou peut être un logiciel, car j'ai lu que d'autre Distros proposaient une modification DPI plus poussée.


    Merci d'avance. ^^
               

  • Si t'as une solution pour que je puisse faire cette commande

    C'est pas une commande à faire, il s'agit d'éditer ton xorg.conf en superutilisateur et d'ajouter cette ligne

    Option "DPI" "96 x 96" 
    dans la section Monitor de ton xorg.conf et de rebooter.
  • Tatou.... Je comprend pas. ><
    Faut aller où exactement ? Dans le terminal ?
    J'ai entré les trucs qui sont pas des commandes dedans mais ça me met *bash: Option : commande introuvable*

    Can you please explain me step by step ? ^^

    Autre souci... j'ai refais les systèmes encore. Mais là, Deepin à pas détecter le boot de Windows 10. :(

    Nuit
Connectez-vous ou Inscrivez-vous pour répondre.