Mise à jour

Bonjour à tous.

La mise à jour ne fonctionne toujours pas chez moi:

Bloqué sur la 15.2.... à jour !

Quelle serait la bonne méthode pour réinstaller sans risque ou forcer la réinstall ?

Commentaires

  • Salut Betov, c'est bizarre que tu restes bloqué sur 15.2 ? 

    Pourrais-tu nous afficher le résultat de cette commande : 
    lsb_release -a
    cat /etc/apt/sources.list

  • Merci. Cela répond:
    No LSB modules are available. (sic).


  • es-tu bien sur d'avoir mis le "-a" apres ta commande lsb_release ? 

    Qu'en est-'il du retour de la seconde commande ?
  • Oui pour le -a (je viens de vérifier).

    Pour la seconde commande, réponse:

    ## Auto-genere par Deepin-fr
    deb [by-hash=force] "http://ftp.gwdg.de/pub/linux/linuxdeepin/" unstable main contrib non-free


  • As tu les outils deepin-tools installé ?
    Si oui, alors peux tu :
    - Vérifier d'avoir une connexion internet et lancer deepin-tools 
    - cocher : "Dépot original"
    - cocher : "Dépot plus rapide"
    - cocher : "Mettre a jour la distrbution" > et valider 
    - et patienter !
  • 6 mars modifié
    'ai une longue liste de mises à jour qui se termine par:

    Ign:12 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/non-free i386 Packages
    Ign:13 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/non-free all Packages
    Err:3 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/main amd64 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Err:5 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/main i386 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Ign:7 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/main all Packages
    Err:8 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/contrib amd64 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Err:9 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/contrib i386 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Ign:10 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/contrib all Packages
    Err:11 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/non-free amd64 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Err:12 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/non-free i386 Packages
      404  Not Found [IP : 134.76.12.6 80]
    Ign:13 http://ftp.gwdg.de/pub/linux/linuxdeepin unstable/non-free all Packages
    17,4 ko réceptionnés en 2s (7 792 o/s)
    Lecture des listes de paquets... Fait
    W: The repository 'http://ftp.gwdg.de/pub/linux/linuxdeepin unstable Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/main/binary-amd64/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/main/binary-i386/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/contrib/binary-amd64/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/contrib/binary-i386/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/non-free/binary-amd64/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    W: Failed to fetch http://ftp.gwdg.de/pub/linux/linuxdeepin/dists/unstable/non-free/binary-i386/Packages ; 404  Not Found [IP : 134.76.12.6 80]
    E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

    /!\ Erreur:

    Une erreure est intervenu dans le script, merci de le signaler directement sur notre forum :
    => http://hub.deepin-fr.org

  • Désolé. Je n'arrive pas à remettre mon dernier message en mode normal. J'ai bien cliqué sur la roue mais je ne peux pas sélectionner le formatage.
  • Je te l'ai reformatté.

    Concernant la mise-a-jour tu es toujours sur l'ancien dépot, on va bypasser le dépot plus rapide :!

    - Vérifier d'avoir une connexion internet et lancer deepin-tools 
    - cocher : "Dépot original"
    - cocher : "Mettre a jour la distrbution" > et valider 



  • Yé. Rien compris, mais comme on dit en mystique, il n'est pas nécessaire de comprendre. >:)

    Merci pour ta patience.
  • Il n'y a rien de mystique :)

    En fait je suspectais qu'un dépo n'était plus fonctionnel (ftp.gwdg.de).
    Du coup, je t'ai fais exécuter les actions suivantes :
    -  "Dépot original" => Qui remplace ton mauvais dépot par le dépot chinois (il est long mais il officiel :p)
    -  "Dépot plus rapide" => Cette option va remplacer ton dépot officiel chinois par un dépot plus proche de ta connexion
    -  "Mettre a jour la distrbution" => Finallement on met a jour tous nos paquets avec le dépot séléctionné plus haut...

    Pas de chance pour nous, l'option "depot plus rapide" pointe vers "ftp.gwdg.de".
    Donc un nouvel echec !

    Du coup, je t'ai fais remettre le dépot officiel et relancer simplement une mise-à-jour...
    Ca va être long, mais au moins ca écarterai le dépot déffectueux.



  • Il me semblait avoir testé le dépôt officiel, par le passé, sans plus de succès... J'ai dû cumuler les fausses manips...

    Le plus étrange est que le logiciel de choix des dépôts s'est remis tout seul sur son dépot rapide (pour moi un dépôt universitaire allemand -DE-), bien que, vu le temps passé, il ait probablement fait un tour par la chine. Pas oser vérifier...

    Qu'est-ce que c'est que "gwdg"? Mon dépôt se nomme Erlangen-Nuremberg.
  • Bonjour,j'ai le même Pb que Betov. Depuis l'installation, je ne peux pas obtenir les mises à jour, ni avec update dans le terminal, ni avec le centre de contole; Le motif donné est:"Impossible de verrouiller le répertoire d'administration ( /var/lib/dpkg/ )
  • j'ai également une erreur dans la mise à jour du cache:
    "malformed entry 2 in list file  /etc/apt/sources.list  'URI parse )
    Merci pour votre aide

  • Désolé, j'ai oublié de mentionner un autre bug: chez moi ( 15-3 ) Deepin-tools ne se lance pas en cliquant sur l'icône mais seulement en utilsant le terminal.
  • @Berluci,
    Pour deepin-tools, je suis actuellement en train de reprendre mon code...

    Déja, pourrais-tu nous dire si tu es en version 15.3 ou 15.4 ? 

    Si 15.3, tu peux réaliser ces actions : 
    - Vérifier d'avoir une connexion internet et lancer deepin-tools 
    - cocher : "Dépot original" 
    - cocher : "Dépot plus rapide"
    - cocher : "Mettre a jour la distrbution" > et valider  


    Mais nous t'encouragerons a passer sur 15.4 :D 
  • Bonjour,
    Effectivement je suis passé à la 15-4 et je n'ai eu aucune difficulté à faire les mises à jour et un "upgrade" après installation, mais maintenant au démarrage ce matin j'ai un souci avec l'ouverture du centre de contrôle.  Quel est le script pour passer par le terminal ?Merci
  • arf... je pense que la mise-a-jour a du mal se terminer...

    Je pourrais te conseiller des commandes pour analyser et diagnostiquer ton soucis...
    Mais je pense que le plus simple dans ton cas sera de réinstaller ton système avec la dernière version 15.4.

    Ce sera bcp plus propre que de corriger une mise a jour 15.3 à 15.4... crois moi ^^
  • Bonjour ,Je me suis mal expliqué:  je n'ai pas fait une mise à jour de 15-3 vers 15-4 mais une réinstallation complète à partir d'un nouvelle image disque 15-4 téléchargée.L'installation faite , j'ai fait "sudo .....upgrade" et ensuite "sudo...update" ce qui n'était peut être pas une bonne idée. Tout à bien fonctionné tant que je n'ai eu à rallumer mon ordi le lendemain. Si necessaire je peux réinstaller  la même image sur la même partition.
  • oui c'est étrange qu'une mise-a-jour te casse ton systeme...
    Je t'invite donc a recommencé ^^
    C'est pas tres pro, mais au moins ce sera fait
  • J'ai réinstallé avec 15-4, tout a l'air de fonctionner normalement.Merci
Connectez-vous ou Inscrivez-vous pour répondre.